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Dreamweaver 4

Dreamweaver priru¢nik vas vodi korak po korak kroz izgradnju web
stranica.Naucit cete kako primjenjivati Macromedia Dreamweaver da bi
izradili svoj sajt, te kako primjenjivati Dreamweaver izbornike i alate za
stvaranje i uredivanje Web dokumenata.

U ovom priruc¢niku, stvorit ¢ete web stranice «Compass-a» , zamiSljene
tvrtke specijalizirane za pustolovna putovanja. Ako niste navikli na
Dreamweaver, pocnite od pocetka prirucnika i stvorite vlastitu metodu
izrade stranica. Ako vam je Dreamweaver ve¢ poznat, mozete zapoceti s
poglavljem “Upotreba Assets panela” na stranici 30.

Ovo poglavlje, te ona koja slijede usmjerena su na nova ili promijenjena
svojstva u Dreamweaveru kao Sto su Assets panel, Flash gumbi i tekst,
koristenje predlozaka, izrada opisa stranice i dodavanje biljeske o izradi
stranice.

Da bi proradili ove lekcije trebat ¢e vam priblizno jedan do dva sata,
ovisno o vaSem iskustvu, a usmjerene su na slijedece zadace:

* Definiranje vlastitih web stranica

* Kreiranje stranica u Layout nacinu prikaza

* Umetanje slika i rollover slika

® Rad sa tablicama u Standard nacinu prikaza
® Kreiranje linka prema drugom dokumentu

* Umetanje aktivnih objekata iz Assets panela
* Umetanje Flash teksta i Flash gumba

® Kreiranje i primjena predlozaka

® Izrada opisa stranice

®* Dodavanje biljeske o dizajnu

Napomena: Ovaj priruénik prikazuje neka svojstva koja su podrzana
samo u 4.0 ili novijim pretrazivacima.



Vodi¢ kroz Dreamweaver

Prije nego zapocnete, pregledajte film «Guided Tour» da biste se
upoznati s procesom izrade stranica te s osobinama Dreamweavera.

1. U Dreamweaveru izaberite Help> Guided Tour.
2. Kliknite naslov filma.
3. Iskljucite film nakon zavrSetka.

Radna povrSina Dreamweavera

Zapoc¢nimo sa kratkim pregledom Dreamweaver radne povrSine.

* Ako ve¢ niste pokrenuli Dreamweaver, kliknite na Dreamweaver
ikonu za pokretanje programa

* Radna povrSina Dreamweavera objedinjuje viSe nac¢ina rada

Nakon §to ste pokrenuti Dreamweaver, otvorit Ce se slijedece stavke
radne povrsine:
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* Prozor dokumenta prikazuje dokument dok ga vi kreirate i uredujete.
* «Objects panel» sadrzi ikone na koje kliknete da bi umetnuli objekt u
va$§ dokument ili izmjenili stanje u dokumentu.



®* Dreamweaver vam nudi mnostvo izbornika, kao §to su <HTML Styles»
izbornik i «Code inspector», koji vam omogucuju rad s drugim
elementima Dreamweavera.

* «Launcher bar» sadrzi gumb za otvaranje i zatvaranje vasih najceSce
koristenih kontrola i izbornika.

* «Property inspector» prikazuje svojstva objekata ili teksta, i dozvoljava
vam promjenu tih svojstava. (Koja svojstva se pojavljuju u Property
inspectoru ovisi o objektu koji je odabran u dokumentu.)

Da bi otvorili Dreamweaver kontrole i izbornike koristite «Window»
izbornik. Kvacica pored stavke unutar Window izbornika oznacuje koja
stavka je trenutno otvorena (mada mozZe biti prikrivena iza drugih
izbornika). Da bi prikazali stavku koja nije trenutno otvorena, odaberite
stavku iz izbornika ili koristite njenu kraticu na tipkovnici.

Rad u Dreamweaveru

Dreamweaver moze prikazati dokument na tri nacina: «Design view»,
«Code view» i razdijeljeno, gdje je prikazano oboje .Da bi izmjenili vrstu
prikaza na kojem radite, oznacite prikaz u Dreamweaver traci s
alatima.

Kod standardne postave, Dreamweaver prikazuje prozor dokumenta
unutar Design prikaza. Naknadno, mozete raditi sa Dreamweaver
Design prikazom na dva razli¢ita nacina, Layout prikaz i Standard
prikaz (oznacite ove prikaze u View kategoriji Objects izbornika.)

Unutar Layout prikaza mozete kreirati sadrzaj stranice, umetnuti slike,
tekst, i druge objekte dok unutar Standard prikaza, dodatno mozete
takoder umetnuti layere, kreirati frame dokumente, tablice, i izvrS§iti
druge izmjene vaSe stranice — mogucnost koja nije dostupna unutar
Layout prikaza.

Na koji nacin su pripremljene datoteke prirucnika

DovrSene i djelomi¢no dovrSene HTML datoteke iskoriStene unutar ovog
prirucnika su unutar mape «Compass_Site» koja je unutar «Tutorial»
mape. Slike i druge pridruzene datoteke sajta su takoder unutar
“Compass_Site” mape.

Svaka datoteka priruénika ima odredeno ime — na primjer, HTML
datoteka koja sadrzi podatke o odredistu putovanja je nazvana
«Destinations.html». Djelomi¢no dovrSene datoteke na kojima radite
imaju imena slicna dovrSenim datotekama, osim $to pocinju sa DW4_.
Djelomi¢no dovrSena verzija Destinations.html, na primjer, nazvana je
DW4_Destinations.html.



Pregledajte citav Web sajt

Pogledajte stranice unutar cijelog Web sajta da bi dobili ideju §to cete
raditi.

1. Ako ve¢ niste, pokrenite Dreamweaver.

2. U Dreamweaveru, odaberite File > Open. U dijaloSkom okviru za
pregledavanje datoteka, odaberite mapu Dreamweaver 4 (gdje ste
instalirali Dreamweaver) a zatim odaberite Tutorial/Compass_Site.

3. U mapi Compass_Site odaberite CompassHome.html a zatim
kliknite Open da bi otvorili «Compass» pocetnu stranicu u prozoru

dokumenta. Ne uredujte ovu stranicu jer cete kreirati vasu vlastitu
verziju ove stranice.

4. Odaberite File > Preview in Browser i odaberite pretraziva¢ u kojem
cete pregledati Compass pocetnu stranicu. Koristite verziju 4.0 ili
noviji pretraziva¢ da bi pregledali ovaj sajt.
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. Premjestite pokaziva¢ iznad navigacijskog gumba da bi vidjeli efekt
rollover slike. Kliknite navigacijski gumb da bi pretrazivali sajt.

. Zatvorite pretraziva¢ nakon Sto ste zavrsili pregledanje sajta.

. Otvorite novi prazni dokument u Dreamweaveru i odaberite File >
Open.

. Zatvorite CompassHome.html datoteku, koja je otvorena u
Dreamweaveru.



Postavite sadrzaj sajta prirucnika

Postoje dva nac¢ina kako mozete raditi sa datotekama priru¢nika —
koristite veé¢ definirani lokalni sajt ili odredite novi.

* Ako ste novi u Dreamweaveru, mozete odabrati lokalni sajt
prirucnika pa cete znati na koji nacin postaviti lokalni sajt nakon Sto
budete spremni izraditi vas vlastiti sajt.

* Ako veé znate definirati sajt koriste¢i Dreamweaver, mozete koristiti
ve¢ definirani sajt priruc¢nika. U Dreamweaver glavnom izborniku
odaberite Site > Open Site, zatim odaberite - Tutorial Dreamweaver.

«Tutorial Dreamweaver» sajt povezuje vas sa Compass_Site datotekama
smjeStenim unutar Dreamweaver 4/Tutorial mape. Nakon selektiranja
lokalnog sajta, predite na “Kreirajte pocetnu stranicu sajta” na stranici
8 prirucnika.

Napomena: Ako odaberete ve¢ definirani sajt, ime sajta prikazano unutar slike
priruénika nece vrijediti.Umjesto imena my_tutorial, vidjet cete — Tutorial
Dreamweaver kao ime sajta na vasem zaslonu.

Definirajte lokalni sajt

Posto ste definirali lokalni sajt odredite gdje planirate pohraniti sve
datoteke za odreden sajt. Da bi djelotvorno radili u Dreamweaveru
uvijek definirajte lokalni sajt za svaku Web stranicu koju kreirate.

Za ovaj prirucnik, navedite Compass_Site mapu kao mapu lokalnog
sajta.

1. Ako vec nije, pokrenite Dreamweaver.
Otvorit ¢e se prazni dokument

2. Odaberite Site > New Site.

3. Unutar dijaloskog okvira Site Definition provjerite dali je Local Info
oznacen unutar Category liste.

4. Unutar Site Name polja upiSite my_tutorial. Ime sajta omogucava
vam da lako prepoznate i odaberete sajt sa popisa sajtova koje ste

kreirali.

5. Kliknite na ikonu mape na desnoj strani Local Root Folder polja.



6. Unutar dijaloSkog okvira koji ¢e se pojaviti, odaberite mapu
Tutorial/Compass_Site, i uradite slijedece:

*U Windows, kliknite Open, zatim kliknite Select nakon §to se
Compass_Site pojavi unutar Select polja.

®* Na Macintoshu, kliknite Choose da bi odabrali Compass_Site mapu.
Local Root Folder polje se azurira da bi se prikazala putanja do
lokalnog sajta.
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Napomena : cijela putanja do mape «Compass_Site» se moze razlikovati, ovisno
o mjestu gdje ste instalirati Dreamweaver.

7. U polju Cache, uradite slijedece:
* Oznacite Enable Cache (Windows) da bi kreirali cache datoteku sajta.

* Odaberite Use Cache to Speed Link Updates (Macintosh) da bi
kreirali cache datoteku sajta.

Cachiranje datoteka unutar Compass_Site mape kreirat ce
vjerodostojan zapis postoje¢ih datoteka tako da Dreamweaver moze
brzo obnoviti linkove nakon §to premjestite, preimenujete, ili izbriSete
datoteke.

8. Kliknite OK da bi zatvorili dijaloski okvir.



9. Kliknite OK na cache poruci.

Nakon toga Site prozor prikazat ¢e listu svih mapa i datoteka unutar
lokalnog sajta. Lista takoder sluzi kao «file manager» koji dozvoljava
kopiranje, umetanje, brisanje, premjeStanje, i otvoranje datoteka.
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Kreirajte poCetnu stranicu

Sada kada je sastav sajta podeSen za spremanje stranica i pojedinih
dijelova “Compass” sajta, kreirat c¢ete prvu stranicu —  pocetnu
stranicu sajta. Tijekom izrade ove stranice, dodat cete slike, tekst, i
Flash animacije tako da ¢e vas dokument sadrzavati iste komponente
kao i pocetna stranica “Compass-a”.

Pohranite vas dokument

Zapocnite spremanjem dokumenta na kojem radite.

1. Ostavite Site prozor aktivan te kliknite prozor dokumenta da bi
aktivirali dokument. Site prozor ostaje otvoren u pozadini.

2. Odaberite File > Save.

3. Unutar Save As dijalo§kog okvira, odaberite Compass_Site mapu
kao lokaciju za vas dokument.

4. Unutar File Name polja, upiSite my_CompassHome.html.
5. Kliknite Save.

Mozete primijetiti da se sada ime dokumenta pojavljuje na vrhu prozora
dokumenta.
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Odredite naslov stranice

Premda dokument ima ime, moZete primijetiti da je jo§ uvijek oznacen
sa Untitled Document. To je zbog toga jer mu trebamo pridodati HTML
ime ili naslov stranice.

Odredivanje naslova stranice pomaZze posjetiocima sajta prepoznati
stranicu koju pretrazuju. Naslov stranice pojavljuje se unutar naslovne
trake pretrazivaca te u bookmark popisu. Ako ste kreirali dokument bez
naslova stranice, dokument ¢e se pojaviti u pretrazivacu sa naslovom
Untitled Document.

U ovom dijelu priru¢nika naslovit ¢ete vasu stranicu.

1. Kada je prozor dokumenta aktivan, odaberite View >Toolbar ako
toolbar nije ve¢ vidljiv. Dreamweaver traka s alatima pojavit ce se
iznad prozora dokumenta

2. Unutar Title polja, upiSite Compass Home Page, zatim kliknite
unutar prozora dokumenta da bi vidjeli dali se naslov stranice
promjenio unutar naslovne trake dokumenta
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3. Spremite datoteku

Kreirajte stranicu u «Layout» izgledu dokumenta

Prvu stranicu cete zapoceti dok radite u Design view-u. Postavit cete
osnovne parametre stranice a zatim umetnuti slike i tekst.

Stranica koju dovrSite u ovom odlomku priru¢nika izgledat ¢e slicno
ovoj stranici.
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Rad u «Layout» izgledu dokumenta

Dreamweaver ima dvije vizualne vrste izgleda kreiranja dokumenta —
Standard izgled i Layout izgled. Pocnite raditi u Layout izgledu
dokumenta, koji vam omoguéava crtanje layout celije ili layout tablice u
koje mozete dodati sadrzaj kao Sto su slike, tekst, ili nesto drugo.

U ovom dijelu priruc¢nika, vi ¢ete postaviti osnovne postavke stranice a
u slijedecem odlomku dodat cete sadrzaj.

1. U Objects panelu, kliknite Layout View ikonu ako nije ve¢ oznacena.

10

T Draw Layout Cell icon
T
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Pojavljuje se Getting Started u Layout View dijaloSkom okviru i
opisuje Layout view opcije.

2. Pregledajte opcije a zatim kliknite OK da bi zatvorili dijalo§ki okvir.
3. U Objects panelu pod Layout prikazane su Layout options — Draw

Layout Cell i Draw Layout Table sada su dostupne.
Ove opcije nisu dostupne u Standard pregledu.



Crtanje layout celija

U Layout izgledu dokumenta mozete crtati layout celije i layout tablice
da bi odredili formu dokumenta. Ovaj zadatak je lakSe izvesti ako
pripremite primjer stranice koju kreirate, prije nego zapocnete samu
izradu stranice.

Pogledajte slijede¢i primjer da bi dobili ideju izgleda stranice koju
kretirate u ovom odlomku priru¢nika. Postoji celija za “Compass”
logotip, tablica sa tri cCelije za navigacijske gumbe, celija za drugu
grafiku, i tablica sa tri Celije koje ¢e sadrzavati tekst.
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Tablice i Celije u vaSem dokumentu crtat cete slicno ovom rasporedu.
Prvo, nacrtajte ¢eliju u koju ¢ete umetnuti “Compass” logotip.

1. Kliknite u prozor dokumenta u my_CompassHome dokumentu da
dokument postane aktivan.

2. Ako ve¢ nisu otvoreni, otvorite slijedece alate:

- Objects panel (izabrati Window > Objects), koji cete koristiti da bi
dodali objekt u vas§ dokument.

- Property inspector (odaberite Window > Properties), koji cete
koristiti da bi postavili svojstva ili osobine za objecte u vasem
dokumentu.

Ako Property inspector vec nije otvoren, kliknite na strelicu za
povecanje u donjem desnom kutu tako da mozete vidjeti sve opcije.

3. U Objects panelu, kliknite Draw Layout Cell ikonu.
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4. Premjestite pokaziva¢ misSa u prozor dokumenta. Pokaziva¢ misa
mijenja se u alat za crtanje (izgleda poput malenog kriza).

Kliknite u gornji lijevi kut dokumenta i povucite da bi nacrtali layout
celiju. PoSto otpustite tipku miSa, layout celija ¢e se pojaviti u layout
tablici.

' Layout
Cell
Lavout
Table

Layout tablica se S§iri i ispunjava prozor dokumenta te odreduje layout
podrudje stranice. Bijeli pravokutnik je layout celija koju ste nacrtali.
Takoder mozete staviti dodatnu layout celiju unutar sivog podrucja
layout tablice.

Promjena veliCine layout celija

Da bi toéno oblikovali stranicu, mozete postaviti zeljenu veli¢inu celija
koju cete dodati u dokument. Mozete takoder premjestiti celije unutar
stranice.

1. Kliknite na rub layout celije da bi je selektirali.

Pojavljuju se "hvataljke" oko oznacene layout celije



2. Da bi promjenili veli¢inu ove layout celije, uradite slijedece:

- U Property inspectoru layout celije, upiSite 510 unutar Fixed polja
da bi postavili Sirinu celije na 510 pixela a zatim kliknite unutar
dokumenta kako bi provjerili dali se §irina €elije izmjenila

Napomena: Ako ste unijeli vrijednost koja je veca od Sirine layout tablice, ili
onu koja uzrokuje preklapanje sa drugom celijom, Dreamweaver c¢e vas
upozoriti i prilagoditi Sirinu ¢éelija na odgovarajucu

- Na desnoj strani layout celije povucite srednju "hvataljku" za
promjenu velic¢ine u desno dok celija nebude Zeljene Sirine.

Pos§to otpustite gumb miSa, Sirina celije se prikazuje u zaglavlju uzduz
gornjeg dijela layout tablice.

Dodavanje viSestrukih celija

Sada cete dodati tri layout celije, ispod celije logotipa koju ste upravo
kreirali. Nakon toga umetnut cete navigacijske gumbe u ove celijje.

1. U Objects panelu kliknite Draw Layout Cell ikonu a zatim drzite
pritisnutu tipku Control (Windows) ili tipku Command
(Macintosh).

2. U prozoru dokumenta, postavite pokazivac ispod ¢elije koju crtate za
logotip a zatim povucite kako bi nacrtali layout ¢eliju. Nastavite
drzati tipku Control (Windows) ili tipku Command (Macintosh) i
nacrtajte jo§ dvije layout celije.

Vas zaslon izgled c¢e slicno ovom:
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Premjestite layout celije

Ako trebate poredati celije jednu do druge mozete ih premjeStati kako
zelite. Izmjenu velicine layout celije vrSite jednom od njezinih
"hvataljki".

Necete moéi kliknuti i povuéi €eliju da bi je premjestili na novu poziciju.
Ako trebate premjestiti layout ¢eliju u dokumentu, ucinite slijedece:

1. Kliknite rub layout celije da bi je oznacili

2. Da bi premjestili layout celiju ucinite slijedece:

Upotrijebite tipke sa strelicama.

Drzite pritisnuto Shift i koristite tipke sa strelicama da bi
premjestili layout c¢eliju 5 pixela odjednom.

Grupirajte celije unutar tablice

Sada cete kreirati tablicu od ¢elija navigacijskih gumba koje ste upravo
kreirali.

Grupiranje celija unutar tablice omogucava vam da kontrolirate
smjesStaj celija i da lako premjestite celije u grupi ako Zzelite izmjeniti
raspored stranice.

Kreirajte tablicu za navigacijske gumbe koja je jednake Sirine kao celija
logotipa.
Koristite Draw Layout Table da bi grupirali slike navigacijskih gumba.

1. Na Objects panelu kliknite Draw Layout Table ikonu.

2. U prozoru dokumenta postavite pokaziva¢ miSa na vrh lijevog kuta
celije prvog navigacijskog gumba te zatim povucite pokazivac tako da
kreirate tablicu od tri ¢elije a da je duljina tablice jednaka duljini
celije logotipa.



3. Otpustite tipku miSa da bi vidjeli éelije grupirane u novu tablicu.

Kreirali ste tablicu koja sadrzi tri celije (bijela povrSina u tablici) i
prazan prostor (siva povrsina u tablici).

PremjeStanje tablice

Mozete odabrati i premjestiti tablicu u drugo podrucje dokumenta.
Nemozete, medutim, premjestiti tablicu tako da se ona preklapa sa
drugom tablicom.

Nakon toga, premjestite tablicu koju ste kreirali, nekoliko piksela u
desno da bi poravnali navigacijske gumbe u donosu na logotip nakon
§to ste ih umetnuli u stranicu.

1. U prozoru dokumenta kliknite tab na tablicu da bi je premjestili .

2. Povucite tablicu nekoliko piksela u desno da bi je premjestili a zatim
povucite jednu od desnih hvataljki za promjenu veli¢ine tablice da bi
poravnali desnu stranu celija logotipa i navigacijskih gumba.

Mozete opaziti, kako kreirate nove tablice i ¢elije, pojavljuju se crte koje
ocrtavaju podrucje. Te crte mozete koristiti za poravnanje rasporeda
elemenata.
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Dodajte jos jednu celiju
Dodajte ¢eliju za Learn More About sliku.

1. Unutar Objects panela, kliknite Draw Layout Cell ikonu.

2. Unutar prozora dokumenta, iscrtajte novu celiju u prostor ispod
tablice navigacijskih gumba.

Vas$ stranica izgled ¢e ovako:

Kreiranje tablice

U proslom odjeljku koristili ste celije za kreiranje tablice. Sada cete
zapoceti sa tablicom i dodati celije.

1. Unutar Objects panela, kliknite na Draw Layout Table ikonu.

2. Premjestite pokaziva¢ miSa u prozor dokumenta. Unutar podrucja
ispod celije koju ste upravo dodali, povucite pokaziva¢ misa u
desno za poravnanje sa desnom stranom najviSe Celije a zatim
povucite prema dnu prozora dokumenta.




Crtanje celija unutar tablica

Sada dodajte ¢elije u koje ¢ete dodati tekst o odrediStima putovanja.

1. Unutar Objects panela, kliknite Draw Layout Cell ikonu i
premjestite pokazivaé na tablici koju ste nacrtali.

2. Nacrtajte celiju veli¢ine priblizno jedne tre¢ine prostora u tablici.

3. Kliknite rub celije da bi je oznacili a zatim u Fixed polju Property
izbornika, upiSite 170 da bi postavili Sirinu celijje.

4. Nacrtajte jo§ jednu celiju veli¢ine priblizno jednu trec¢inu duljine u
tablici odmah do prve celije.

5. Kliknite rub ¢elije da bi je odabrali a zatim u Fixed polju Property
izbornika, upiSite 170 da bi postavili Sirinu éelije.

6. Nacrtajte zadnju celiju u ostatak prostora u tablici. Promjenite
veli¢inu ili premjestite Celiju da bi namjestili veli¢inu ili polozaj ¢elija

koliko je potrebno.

Vas$ zaslon izgledat ¢e ovako:
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Dodavanje sadrzaja stranici

Sada kada ste postavili podruéje stranice, dodat cete graficki sadrzaj
kao §to su logotip i rollover slike.

Umetanje slika

Sada cete nauciti dva nacina za umetanje slika u Dreamweaver —
koristec¢i Dreamweaver glavni izbornik i Objects panel.

1. Kliknite bilo gdje unutar cCelije logotipa (najgornja celija).
Klikajuéi unutar celije odredujete mjesto umetanja u ¢éeliju bez
selektiranja celije.

2. Odaberite Insert > Image

3. Unutar Select Image Source dijaloSkog okvira pronadite
Compass_Site mapu a zatim Assets mapu te mapu sa slikama.
Kliknite compass_logo.gif da bi je selektirali.

4. Provjerite dali je Relative To pop-up izbornik, smjeSten na dnu
dijalo§kog okvira, podesen na Document a zatim kliknite Select
(Windows) ili Open (Macintosh) da bi odabrali sliku.

Slika ¢e se pojaviti unutar celije.

| Lascui Teblk | —
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5. Kliknite bilo gdje u Learn More About celiji da bi odredili mjesto
umetanja u celiju.

6. Unutar Objects panel Common category, kliknite Insert Image
ikonu.

7. Unutar Select Image Source dijalo§kog okvira, pronadite
Compass_Site/Assets/images mapu, i pronadite
learnMoreAbout.gif a zatim kliknite Select (Windows) ili Open
(Macintosh) da bi odabrali sliku.

Slika ¢e se pojaviti u celiji.

8. Odaberite File > Save da bi pohranili izmjene koje ste napravili na
pocetnoj stranici.



Kreirajte rollover sliku

Rollover slika je slika ¢iji se izgled mijenja kada pokaziva¢ miSa prelazi
(“rolls”) preko nje.

Koristite Insert Rollover Image naredbu da bi kreirali tri rollover slike
za navigacijske gumbe — Trip Planner, Destinations, i Travel poruke.

Rollover slika sastoji se od dvije slike, slike prikazane kada se stranica
prvi put ucdita u pretraziva¢ te slike prikazane kada pokaziva¢ misa
prede preko izvorne slike. Slike koje koristite moraju biti jednake
veli¢ine. Prva slika diktira veli¢inu, pa ako je druga slika mnogo manja
ili mnogo veca sve Ce izgledati iskrivljeno ili neprofesionalno izradeno.

Nakon toga céete dodati navigacijski gumb sa rollover slikom a zatim
dodajte ostale navigacijske gumbe i pregledajte stranicu u pretrazivacu
da bi testirali rollover efekte.

1. U prozoru dokumenta kliknite unutar prve celije u tablici
navigacijskih gumba.Ovime odredujete gdje Zelite umetnuti sliku.

2. Da bi umetnuli rollover sliku ucéinite slijedece:
* U Common kategoriji Objects panela, kliknite ikonu Insert
Rollover Image.
* Odaberite Insert > Interactive Image >Rollover Image.

3. U dijaloski okvir Insert Rollover Image, upiSite planner u polje
Image Name.Ovo daje slici jedinstveno ime, i ¢ini je lako
prepoznatljivom u HTML kodu.

4. U polju Original Image kliknite Browse a zatim odaberite
MenuTripPlanner.gif i kliknite Select (Windows) ili Open
(Macintosh).Ovime odredujete koja cCe se slika prikazati kada se
stranica ucita prvi put.

5. U polju Rollover Image kliknite Browse a zatim odaberite
MenuTripPlanner on.gif i kliknite Select (Windows) ili Open
(Macintosh).Ovime odredujete koja ce se slika prikazati kada je
pokaziva¢ misSa iznad originalne slike.
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6. Provjerite dali je odabrana Preload Rollover Image opcija kako bi se

rollover slika ucitavala kada se stranica ucitava u pretrazivac,

osiguravajuéi brzu promjenu slika kada korisnik pomakne pokazivac
miSa iznad originalne slike.
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7. Kliknite OK da bi zatvorili dijalo§ki okvir.

Slika ce se pojaviti u dokumentu.

8. Promijenite veli¢inu celije da bi prilagodili sliku ¢eliji.

Kreirajte druge rollover slike

Sada cete dodati rollover slike za druge navigacijske gumbe.

1.

10.

11.

Kliknite unutar celije drugog navigacijskog gumba te zatim u
Common kategoriji Objects panela, kliknite Insert Rollover Image
ikonu.

U Insert Rollover Image dijaloski okvir upiSite ,,destinations* u
polje Image Namekako bi osigurali da slika ima jedinstveno ime.

U Original Image polje kliknite Browse a zatim odaberite
MenuDestinations.gif.

U polje Rollover Image kliknite Browse a zatim odaberite
MenuDestinations_on.gif.

Provjerite dali je odabrana opcija Preload Rollover Image a zatim
kliknite OK da bi zatvorili dijalo§ki okvir.

Kliknite unutar celije treceg navigacijskog gumba a zatim u
Common kategoriji Objects panela kliknite ikonu Insert Rollover

Image.

U Insert Rollover Image dijaloSkom okviru upiSite «travellog» u
polje Image Name kako bi osigurali slici jedinstveno ime.

U polju Original Image kliknite Browse a zatim odabrite
MenuTravelLogs.gif.

U polju Rollover Image kliknite Browse a zatim odabrite
MenuTravelLogs_on.gif.

Provjerite dali je odabrana opcija Preload Rollover Image a zatim
kliknite OK da bi zatvorili dijalo§ki okvir.

Veli¢inu ¢elija prilagodite veli¢ini slika.



Pregledajte vas dokument

Necete modéi vidjeti rollover efekte unutar Dreamweaverovog prozora
dokumenta jer rollover slika radi jedino u pretrazivacu. Nemorate
pohraniti dokument prije nego Sto ga pregledate u pretrazivacu.

1. Stisnite F12 da bi vidjeli dokument u pretrazivacu.

FOmPAEEN

= THRIF PLANNER = DEBTINATIONS = TRAVEL LOOSE

LIAEN MARE bRanT

Premjestite pokaziva¢ miSa iznad rollover slike kako bi vidjeli rollover
efekt.

2. Nakon §to ste zavrSili pregled zatvorite pretrazivac .

3. Vratite se u prozor dokumenta Dreamweavera i odaberite File >Save
kako bi pohranili izmjene koje ste napravili na pocetnoj stranici.
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Umetanje teksta

Sada c¢ete dodati tekst u celije u podnozju tablice.

U Dreamweaveru mozete upisati sadrzaj izravno u celiju ili mozete
izrezati i nalijepiti sadrzaj iz drugog dokumenta. U ovom poglavlju
dodat cete tekst u celiju kopirajuéi i lijepe¢i sadrzaj iz prethodno
kreirane tekstualne datoteke.

1. Odaberite File > Open a zatim u Compass_Site mapi otvorite
DW4_HomeText.txt.

Dokument DW4_HomeText.txt otvorite u novom prozoru
dokumenta Dreamweavera.

2. U DW4_HomeText.txt odaberite prve dvije linije teksta, “Fly
Fishing” do “ravioli.”

3. Odaberite Edit > Copy da bi kopirali tekst.

4. Unutar my_CompassHome dokumenta kliknite u prvu celiju u
tablici teksta

5. Odaberite Edit > Paste da bi nalijepili tekst u celiju.

6. U DW4_HomeText.txt odaberite slijedece dvije linije teksta, “Level 5
Rapids”do “Siberia.”

7. Odaberite Edit > Copy da bi kopirali tekst.

8. U my_CompassHome dokumentu kliknite u drugu celiju unutar
tablice teksta

9. Odaberite Edit > Paste da bi nalijepili tekst u celiju.

10. U DW4_HomeText.txt odabrite zadnje dvije linije teksta, “Puget
Sound Kayaking” do “Puget Sound.”

11. Kopirajte tekst te ga zatim nalijepite u trecu celiju u tablici.

12. Zatvorite DW4_HomeText.txt a zatim kliknite u
my_CompassHome.html da bi dokument ostao aktivan.

Formatirajte tekst

Tekst mozete formatirati unutar prozora dokumenta postavljanjem
svojstava unutar Property izbornika. Prvo, odaberite tekst koji zelite
formatirati, zatim izmjenite vrstu fonta i veli¢inu teksta.

1. Ako Property izbornik nije otvoren odaberite Window > Properties.

2. Unutar prve tekst celije odaberite cijeli tekst od rijec¢i “Fly,” do zadnje
rijeci “ravioli.”



3. U drugom Format izborniku Property inspektora koji je trenutno
postavljen na Default Font, odaberite Verdana, Arial, Helvetica,

sans-serif.
4. U Size izborniku odaberite 2.

Tekst u vasem dokumentu automatski ¢e prikazati izmjene.

5. Ponovite gornje korake da bi odabrali i oblikovali tekst u druge dvije
tekstualne celije.

Upotrijebite boje i stilove
Sada cete primijeniti dodatne izmjene u tekstu, boju i stil, da bi kreirali

naslov teksta.

1. U prvoj tekst celiji odaberite tekst naslova od rijec¢i “Fly,” do rijeci
“Mountains.”

2. U Property inspektoru kliknite izbornik boja a zatim premjestite alat
na sliku Learn More About u prozoru dokumenta i odaberite smedu
boju teksta unutar slike.

3. Kliknite B ikonu da bi primijenili podebljan stil teksta.

4. Ponovite gornje korake da bi primijenili boje i stil naslova u drugim
celijama.

5. Stisnite F12 da bi pregledali vasu stranicu u pretrazivacu.
Vas$a stranica bi trebla izgledati isto kao stranica ispod.
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Pogledajte tekst. Postoji maleni razmak izmedu teksta u celijama. To
¢ete ispraviti u narednim lekcijama u priruéniku.

6. Zatvorite pretrazivac¢ a zatim kliknite unutar prozora dokumenta da
bi postao aktivan.
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Rad u standardnom izgledu dokumenta

Layout izgled je koristan za postavljanje strukture Web stranice. Iako
mozete regulirati veéinu elemenata za kreiranje u Layout izgledu neke
izmjene moraju biti dovrSene u standardnom izgledu. Kada ukljucite
standardni izgled vidjet ¢ete na koji nac¢in Dreamweaver koristi tablice
za kreiranje strukture stranice. Layout tablice u Layout izgledu su
<table> tagovi u standardnom izgledu.

Sada cete nauciti kako raditi sa tablicama i nastaviti fino podeSavanje
dizajna stranice.
Prvo ukljucite u Dreamweaveru standardan izgled.

* U Objects panelu kliknite Standard View ikonu.

Vas$ stranica bi trebala izgledati kao slika ispod.
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Postavite svojstva celije

Visina celije odreduje visinu prostora unutar celije.Pogledajte prostor
oko «Compass» logotipa. Ako zelite ukloniti viSak prostora izmedu
logotipa i navigacijskih gumba ucinite slijedece:

1. Kliknite bilo gdje u prazno podrucje ¢elije koja sadrzi sliku «Compass»
logotipa (ali ne i na sliku ).

2. U celiji Property inspektora, unutar polja H (visina) koja opcenito
sadrzi neku vrijednost, obriSite upisanu vrijednost.

3. U Property inspektoru kliknite Bg color ikonu smjeStenu u podnozje
Property inspektora a zatim upotrijebite izbornik boja da bi odabrali

crnu boju. Boja pozadine se pojavljuje u celiji.

4. Kliknite bilo gdje u prozor dokumenta da bi vidjeli izmjene.



Selektiranje tablice

Sada cete podesiti prostor unutar tablice navigacijskih gumba. Najlaksi
nacin za selektiranje tablice u #“Standard+ izgledu je koriStenje tag
biraca koji prikazuje HTML tagove elemenata unutar dokumenta.

Korist cete tag bira¢ za oznacavanje tablice koja sadrzi navigacijske
gumbe.

1. Kliknite unutar celije koja sadrzi sliku #Trip Planner~.

Mozete primijetiti tag izbornik lijevo u podnozju prozora dokumenta.
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Napomena: tagovi u vaSem tag izborniku mogu se razlikovati na temelju broja
tablica koje ste kreirali u Layout izgledu dokumenta.

2. Unutar tag izbornika kliknite <table> tag.
Unutar prozora dokumenta pojavit ¢e se obrub oko tablice
navigacijskih gumba, pa Property inspektor sada odrazava svojstva

tablice.
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Postavite svojstva tablice

Sada cete upotrijebiti Property inspektor tablice da bi ocistili dodatni
prostor unutar tablice navigacijskih gumba te dodali boju pozadine
unutar tablice.

1. U Property inspektoru kliknite Clear Row Heights ikonu. To je gumb
na vrhu lijevo, na donjoj polovini Property inspektora.

Dodatni prostor nestaje iz tablice.
2. U Property inspektoru kliknite Bg Color ikonu a zatim upotrijebite

alat za izbor boje da bi odabrali crnu boju.
Crna boja pozadine je u tablici navigacijskih gumba.
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Dodavanje prostora u celiju

Sada cete napraviti izmjene u celiji koja sadrzi tekst. Kao Sto vidite,
tekst je previSe blizu rubu celije. Vi cete dodati prostor u celiju kako bi
povecali razmak izmedu teksta i ruba celije.

1. Kliknite u prvu ¢eliju u tablici teksta.
2. U tag izborniku kliknite <table> tag da bi oznacili tablicu.

3. U polje CellPad Property inspektora, unesite 10 kako bi dodali 10
piksela prostora izmedu teksta i ruba celije.

4. Kliknite bilo gdje unutar prozora dokumenta kako bi vidjeli izmjene.

5. Pohranite vas dokument.

Pregled datoteka sajta

Da bi vidjeli slikovito predocenje strukture sajta, upotrijebite Site Map
pregled. Mozete , takoder, upotrijebiti Site map kako bi dodali nove
datoteke sajtu; dodali, uklonili i izmjenili linkove te kreirali graficku
datoteku koju tada mozete eksportirati te ispisati u nekoj od aplikacija
za obradu slika.

Site map uvijek prikazuje pocetnu stranicu sajta na vrhu a ispod
pocetne stranice mozete vidjeti na koje datoteke pocetna stranica ima
linkove.

Postoji mnogo nac¢ina kako definirati po¢etnu stranicu. Najlaksi nacin
je upotreba kontekst izbornika unutar prozora sajta.

1. Kliknite naslovnu traku u prozoru sajta kao bi postao aktivan. (Ako
prozor sajta nije vidljiv, odaberite Window > Site Files.)

2. U popisu Local Folder u prozoru sajta, kliknite desnom tipkom miSa
(Windows) ili Control-click (Macintosh) na my_CompassHome.html
a zatim u kontekst izborniku odaberite Set as Home Page.

3. Kliknite Site Map ikonu na vrhu lijevog podrucja prozora sajta a
zatim u SiteMap pop-up izborniku odabrite Map and Files.

=l .T— i [rp_tubxial a8 x|@

Site Map icon



Prozor sajta se sada pojavljuje sa dvije vrste pregleda vaSeg sajta, na
lijevoj strani je mapa sajta koja graficki prikazuje trenutni sastav
Compass sajta (sa my_CompassHome.html kao poc¢etnom stranicom), a

na desnoj strani je popis sadrzaja trenutne mape.
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My_CompassHome.html stranica trenutno nema linkova.
U slijedecem odlomku ovog priru¢nika dodat cete linkove na ovu

stranicu.

Ostavite za sada Site prozor otvoren, tako da mozete vidjeti na koji
nacin se mapa sajta obnavlja dok vi dodajete linkove na pocetnu

stranicu.
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Povezite vase dokumente

Slike na vrhu «Compass» poCetne stranice vode posjetioce na odredene
stranice sajta. Sada ¢ete dodati linkove za navigacijske gumbe.

Vidjet ¢ete nacine kako kreirati linkove koriste¢i Dreamweaver. Prvo,
dodat cete link slici Trip Planner na TripPlanner.html stranici

koristeci Property inspektor.

1. Unutar prozora Site kliknite dvaput na ikonu
my_CompassHome.html datoteke

My_CompassHome.html datoteka ce postati aktivni prozor.

2. U prozoru dokumenta, kliknite jedanput na sliku Trip Planner da bi
je oznagili .

3. Odaberite Window > Properties kako bi otvorili Property inspektor
ako vec nije otvoren.
Property inspektor prikazuje informaciju o odabranoj slici.
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Napomena: Polje link sadrzi znak (#) koji se ¢esto odnosi na nepostojeéi link,
kreiran nakon §to ste umetnuli rollover sliku. Nemojte ukloniti ovaj znak jer ée
ubrzo biti zamijenjen sa imenom datoteke na koju ste napravili link.

4. U Property inspektoru kliknite ikonu mape na desnoj strani polja
Link.

5. Unutar dijaloSkog okvira Select File pronadite Compass_Site mapu
te zatim u DW4_TripPlanner.html kliknite Select (Windows) ili
Open (Macintosh) kako bi oznacili datoteku koja ce se otvoriti nakon
§to kliknete na gumb Trip Planner.

Ime datoteke se pojavljuje unutar polja Link Property inspektora.
Sada cete dodati link na sliku Destinations koriste¢i Property
inspektor i prozor Site.

6. Kliknite naslovnu traku prozora Site kako bi ga uc¢inili aktivnim ili
odaberite Window > Site Files. Ako je potrebno promijenite veli¢inu
vaseg prozora dokumenta tako da mozete smjestiti lijevu stranu
prozora dokumenta i prozora Site jedan uz drugoga.

7. Unutar prozora dokumenta, kliknite sliku Destinations kako bi je
oznacili.



8. Unutar Property inspektora kliknite ikonu Drag to File (smjeStenu
na desnoj strani polja Link) a zatim vucite pokaziva¢ miSa na prozor

Site u popisu Local Folder i usmje
DW4 Destinations.html.
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Ime datoteke se pojavljuje u polju Link Property inspektora.

9. Kliknite ikonu Site Map u prozoru Site. Karta sajta ¢e se obnoviti
kako bi bili prikazani linkovi koje ste dodali.

p_Cemparsteme kind

DAl Trigiisenar el D' Derfnallons ..

Znak plus (+) pored bilo koje datoteke u karti sajta oznacava da ta
datoteka sadrzi linkove na druge dokumente. Kliknite znak plus kako
bi povecali kartu sajta te prikazali povezane datoteke; kliknite znak
minus (-) kako bi kartu sajta sazeli.

Sada c¢ete dodati link za sliku Travelogs.
10. U prozoru dokumenta kliknite sliku Travelogs kako bi je oznaéili.

11. U property inspektoru povucite ikonu Point-to-File na prozor Site i
usmjerite na datoteku DW4_Travelog.html.

12. Odaberite File > Save kako bi pohranili izmjene koje ste napravili
na pocetnoj stranici
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Provjerite vasu stranicu

Kako bi bili sigurni da stranice funkcioniraju kako vi o¢ekujete, linkove
nemozete provjeriti u Dreamweaveru vec u pretrazivacu.

1. Stisnite F12 kako bi pregledali stranicu u pretrazivacu.
Kliknite na navigacijske gumbe kako bi provjerili vase linkove.
Kliknite na gumb Back pretrazivaca kako bi se vratili na vasu
pocetnu stranicu.

2. Nakon S§to ste zavrsili testiranje vase stranice, odaberite File > Close
kako bi zatvorili stranicu.

Upotreba Assets panela

Assets panel omogucava vam pregled dijelova vaSeg sajta kao Sto su
slike, HTML boje, linkovi, flash animacije, druge vrste animacija,
skripte te predlosci.

Mozete pregledati sve dijelove vaSeg sajta na jednom mjestu i zatim
jednostavno dodati sadrzaj vasim stranicama izravno iz panela.

Sada cete nauciti kako koristiti Assets panel kako bi dodali sadrzaj
stranici.

Odaberite novi dokument

Ne trebate kreirati dodatne tablice na vasSoj pocetnoj stranici jer ovaj
prirucnik sadrzi HTML datoteku koja je istovrsna pocetnoj stranici koju
ste kreirali; ona sadrzi novu celiju na desnoj strani dokumenta.

Da bi krenuli sa ovim dijelom priru¢nika uradite slijedece:

* Ako nastavljate prirucnik iz prethodnog odlomka, odaberite File >
Open a zatim oznacite DW4_CompassHome2.html.

* Ako zapocinjete sa priruc¢nikom u ovom odlomku, odaberite Site >
Open Site a zatim u popisu Sites oznacite Tutorial - Dreamweaver
kako bi otvorili oznaceni sajt. U glavnom izborniku prozora
dokumenta odaberite File > Open; u dijaloSkom okviru koji se
pojavljuje oznacite DW4_CompassHome2.html.

Otvorit ¢e se datoteka DW4_CompassHome2.html.
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Pregled dijelova sajta

Zapocnite otvaranjem Assets panela.
1. Otvorite Assets panel na slijedeci nacin:

¢ Odaberite Window > Assets.
¢ Kliknite ikonu Show Asset u izborniku Launcher.

Pojavit ¢e se Assets panel.
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Umetanje slike

Zapocet cete koristiti Assets panel umetanjem dvije slike na stranicu -
slike penjaca i slike sa tekstom.

1. U Assets panelu kliknite ikonu Images i provjerite dali je odabran
radijski gumb Site smjeSten na vrhu Assets panela tako da mozete
pogledati sve slike unutar «Compass» sajta.

2. U popisu Names oznacite ikonu slike climber.jpg a zatim povucite

sliku na srednju celiju tablice na desnoj strani stranice.
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3. Stisnite desnu tipku sa strelicom (ovime cete deselektirati sliku
penjaca i postaviti mjesto umetanja iza slike), stisnite Shift+Enter
(Windows) ili Shift+Return (Macintosh) kako bi umetnuli liniju
prekida(line break).

4. U popisu Name, oznacite Text.gif te je povucite prema liniji prekida

koju ste upravo kreirali i time ¢ete postaviti sliku Text ispod slike
penjaca.

Umetnite Flash animaciju

Sada c¢ete dodati viSe vrsta fajlova. Povuéi ¢ete Flash animaciju u celiju
ispod navigacijskih gumba.

1. Kliknite ikonu Flash u Assets panelu kako bi vidjeli sve Flash
datoteke unutar sajta «Compass»

2. U popisu Name, kliknite welcome.swf kako bi oznacili Flash
animaciju koju ¢ete umetnuti u dokument.

U podrucdju za pregled u Assets panelu mozete vidjeti oznaku mjesta za
Flash animaciju.



3. Kliknite Play gumb u podrudju za pregled Assets panela kako bi
vidjeli Flash animaciju.

F— Flay button

i

o

4. Unutar popisa Names povucite Welcome.swf u celiju ispod Trip
Planner navigacijskog gumba.
Oznaka Flash-a pojavit ¢e se u oznacenoj celiji.

Primjena boja koriStenjem Assets panela

Boje koje primijenjujete na HTML elemente kao Sto su tekst ili boja
pozadine su automatski dodani u kategoriju «boja» Assets panela.
Mozete odabrati boju iz Assets panela i primijeniti na tekst u istoj
stranici ili na drugim stranicama u vasem sajtu.

1. Stavite oznaku mjesta umetanja iza slike penjaca a zatim stisnite
Enter (Windows) ili Return (Macintosh) kako bi dodali novi odlomak
a zatim upiSite Yosemite.

2. Dvaput kliknite Yosemite kako bi selektirali tekst.

3. U Assets panelu kliknite ikonu Colors kako bi vidjeli HTML boje u
«Compass» sajtu.

4. U popisu Value odaberite simbol boje #993300 a zatim povlacenjem
na selektirani tekst primijenite boju.

Kreiranje «favorite assets» liste

Koristite Assets panel kako bi upravljali dijelovima sajta. Unutar Assets
panela mozete kreirati vasu vlastitu skupinu najcéeSce koriStenih
elemenata. Sada cete dodati Compass logotip i sliku navigacijskog
gumba u vasu «Favorites» listu.

1. Unutar Assets panela odaberite ikonu Images.

2. Unutar liste Name kliknite compass_logo.gif kako bi ga oznadcili a
zatim uradite slijedece:

* Kliknite desnom tipkom (Windows) ili Control-click (Macintosh) kako
bi se pojavio kontekst izbornik a zatim odaberite Add to Favorites.
ili

* Kliknite ikonu Add to Favorites smjeStenu u donjem desnom dijelu
Assets panela.

Bit ¢ete upozoreni da je odabrani element dodan u vasu Favorites
listu.

3. Kliknite OK.
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Dodajte odjednom viSe slika u favorites

Sada c¢ete dodati slike navigacijskih gumba u favorites listu. Mozete
odabrati viSe slika unutar Assets panela a zatim ih sve odjednom dodati
u va$ «favorites».

1. Unutar liste Images Assets panela kliknite prvu sliku navigacijskog
gumba (MenuDestinations.gif ).

2. Oznacite ostale navigacijske gumbe na slijedec¢i nacin:

* Stisnite Shift (Windows) te u listi Images kliknite
MenuTripPlanner_on.gif (zadnji navigacijski gumb u listi) kako bi
oznaciti sve slike navigacijskih gumba.

e Stisnuti Shift (Macintosh) i drzite ga dok selektirate svaku sliku
navigacijskih gumba.

3. Kliknite ikonu Add to Favorites.

4. Kliknite OK

Pregledanje «favorite» elemenata

Dijelove koje ste dodali u vasSu «Favorites» listu mozete pregledati i
koristiti preglednik za umetanje dijelova u vas dokument.

Kako bi pregledali slike koje ste dodali u Favorites listu kliknite
Favorites gumb na vrhu Assets panela.

Umetanje Flash objekata

Flash objekti su malene graficke SWF (Shockwave) datoteke koje
mozete kreirati dok radite u Dreamweaveru. Mozete kreirati Flash tekst
i Flash gumbe. Upotrebom Flash teksta omoguceno vam je kreiranje
Web stranice koja koristi nestandardne fontove bez brige o tome koje
fontove posjetilac na vas sajt ima dostupne na svojem racunalu. Flash
gumbi se kreiraju iz Flash predlozaka koji dolaze u sklopu
Dreamweavera. Predlozak za gumb mozete lako prilagoditi i dodati na
vasu Web stranicu.



Kreiranje Flash tekst objekata

Kreirajte Flash tekst objekte kao naslov na vaSoj pocetnoj stranici.

1. U prozoru dokumenta postavite mjesto umetanja iznad slike
penjaca.

2. Unutar Object panela kliknite ikonu Insert Flash Text.

w

Pojavljuje se dijaloski okvir Insert Flash Text.

Fonk [Aaal H G X
ms EzAW ey
Cobe [ [VOO0C0 PiodovarCoke [ | [ _ Caenl |
Tt = | &
| GhosFort _I—|
Linke [ Hirate.
Taget: | = |
Bglokr [ [
Gwmis it ot Hirate.

3. Unutar dijaloSkog okvira Insert Flash Text postavite slijedece opcije:

* Za Font odabrite Verdana ili jedan od vasih omiljenih fontova.

* Za Size unesite 18.

e Za Color kliknite izbornik boja a zatim odaberite smedu boju za
naslovni teksta u dokumentu.

* Za boju Rollover efekta, kliknite izbornik boja a zatim u
prozoru dokumenta odaberite zlatnu boju u pozadini tablice.

* U Text polje unesite Featured Destination.

* U Save As polje unesite myText.swf.

4. Kliknite OK kako bi zatvorili Insert Flash Text dijaloski okvir.
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Pregledajte efekt Flash teksta unutar dokumenta

Flash tekst objekt pojavljuje se unutar dokumenta. Morate pokrenuti
Flash objekt kako bi vidjeli tekst sa rollover efektom.

1. Ako nije razvucen unutar Property inspektora kliknite strelicu za
razvlaéenje kako bi vidjeli sve.

2. Unutar Flash Text Property inspektora kliknite Play.

3. Unutar prozora dokumenta prijedite pokazivacem miSa iznad Flash
teksta.

4. Da bi zaustavili djelovanje efekta kliknite Stop in Property
inspektoru.

Kreiranje Flash gumba

Sada cete vidjeti na koji nacin se dodaju Flash gumbi u dokument.
Kreirat cete Flash gumb i dodati ga ispod slike penjaca.

1. Unutar prozora dokumenta postavite mjesto umetanja gdje zelite da
se objekt pojavljuje, ispod slike penjaca, a zatim u Objects panelu

kliknite ikonu Insert Flash Button.

Pojavit ¢e se Insert Flash Button dijaloski okvir.
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2. Unutar Insert Flash Button dijaloSkog okvira postavite slijedece
opcije:

» U listi Style odaberite Beveled Rect-Bronze.

* Za Button Text upiSite More Details.

* Za Font odaberite Verdana, ili odaberite zeljeni font.

* Za Size upiSite 11.

* Kliknite Apply kako bi vidjeli Flash gumb u dokumentu.
* U Save As upiSite myButton.swf

3. Kliknuti OK kako bi zatvorili dijalo§ki okvir.
Flash gumb pojavit ¢e se u dokumentu.

Pregledajte Flash gumb u dokumentu

Flash gumb koji ste umetnuli ima rollover efekt i sada ¢ete vidjeti kako
izgleda gotov gumb u dokumentu.

1. U Flash button Property inspektoru kliknite Play kako bi aktivirali
animaciju u dokumentu.

2. U prozoru dokumenta povucite pokaziva¢ miSa preko objekta kako bi
vidjeli rollover efekt.

3. Za zaustavljanje animacije kliknite Stop u Property inspektoru.

Kreiranje predlozaka

PredloSke mozete koristiti za kreiranje dokumenata koji imaju
zajednicku strukturu i izgled. PredloSci su korisni kada Zzelite da sve
stranice u sajtu imaju neke zajednicke osobine. Jednom kada
primijenite predlozak na skupinu stranica, mozete mijenjati informacije
na skupini stranica uredivanjem predloSka i ponovnom primjenom
predloska na te stranice. Dok elementi jedinstveni za svaku stranicu
(kao Sto je tekst opisa neke stavke) ostaju nepromijenjeni, zajednicki
elementi predloska (kao Sto su izbornici) mogu se obnavljati na svim
stranicama koje koriste taj predlozak.

Stranica «Compass trip destination» ima linkove na nekolicinu stranica
koje opisuju mjesto u koje posjetioci sajta mogu biti zainteresirani
putovati. Za kreiranje predlosSka koristit cete dizajn postojece stranice o
detaljima putovanja. KoriStenje predloska vam osigurava da vase
stranice sa informacijama o putovanju imaju jednak izgled i oblik.

37



38

Kreiranje predloska iz postojece stranice

U ovom cete odlomku kreirati predlozak iz postojece stranice te zatim
primijeniti predlozak za kreiranje nove stranice.

1. Unutar Local Folder liste dvaput kliknite ikonu
DW4 TravelDetail surf.html kako bi otvorili datoteku.

2. Odaberite File > Save as Template.

Pojavit ¢e se Save As Template dijaloski okvir.
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Postoje¢i predloSci travelDetail i travelDetail v2, su kreirani i
primjenjeuju se na sve stranice o putovanju «Compass» sajta. Vi Cete
kreirati vasu vlastiti verziju ovog predloska.

3. U polju Save As izmjenite ime predloska, upiSite myTravelDetail i
kliknite Save.

Unutar prozora dokumenta novi ¢e dokument zamijeniti
DW4_TravelDetail dokument.U naslovnoj traci dokumenta mozete
opaziti identifikator predlo§ka <<Template>> i ekstenziju datoteke
Dreamweaver predlos§ka (.dwt).

[zmjenite predlozak

Za sada, novi predlozak je isti kao i stranica iz koje ste kreirali
predlozak. Predlozak sadrzi nedostupna i izmjenjiva podrudja.
Nedostupna podru¢ja mogu se uredivati jedino wunutar samog
predloska. Izmjenjiva podrucja su rezervirana za sadrzaj koji je
jedinstven za svaku stranicu u kojoj se predlozak primjenjuje. U vasem
predlosku logotip i navigacijski gumbi se nemogu mijenjati dok su
naslov, banner reklama i opis odrediSta izmjenjivi.

Vas prvi korak je kreiranje izmjenjivih podruc¢ja u predlosku.
1. U predlosku myTravelDetail.dwt, u prozoru dokumenta kliknite

najviSu oznaku Flash animacije kako bi je selektirali. Ova animacija
prikazuje naziv odredista.
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2. Odaberite Modify >Templates >New Editable Region.
Pojavit ¢e se dijaloski okvir New Editable Region.

3. U polje Name, upiSite «titleCell» kao ime za ovo podrucéje predlo§ka.
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Cancel

Help

4. Kliknite OK.
Podrugéje predloska je kreirano. Mozete primijetiti tabulator koji
sadrzi ime podrucja predlo§ka . Oznaka mjesta je takoder okruzena
svjetlo plavom linijom koja oznacava granice izmjenjivog podrucja.

5. U prozoru dokumenta odabrite oznaku za Flash banner a zatim
Modify > Templates > New Editable Region kako bi napravili
izmjenjivo podrucje u predlosku.

6. Unutar polja Name u dijaloSkom okviru New Editable Region
upiSite «<adCell» i zatim kliknite OK.

Oznake podrucja predloska pojavit ¢e se u dokumentu.

7. Unutar prozora dokumenta odaberite ¢itav tekst unutar prve cCelije
ispod bannera, te zatim odaberite Modify > Templates > New
Editable Region kako bi napravili ovo podrucje predloska
izmjenjivim

8. Unutar polja Name u dijalo§kom okviru New Editable Region
upisite «textCelll» te kliknite OK.

9. U prozoru dokumenta oznacite Citav tekst u drugoj celiji ispod
bannera te zatim odaberite Modify > Templates > New Editable
Region kako bi napravili ovaj odlomak predloska izmjenjivim.

10. U polje Name u dijaloSkom okviru New Editable Region upiSite
«textCell2» te kliknite OK.

11. Odaberite File > Save kako bi spremili datoteku predloska.



Upotrijebite predlozak na novoj stranici

Sada kada ste postaviti izmjenjiva podruc¢ja u vas predlozak primjenit
cete predlozak kako bi kreirali stranicu o detaljima putovanja na Novi
Zeland.

1. Odaberite File > New from Template kako bi otvorili novi dokument.
2. U listi Templates unutar Select Template dijaloSkog okvira, odaberite
myTravelDetail a zatim kliknite Select kako bi odabrali predlozak

koji zelite primijeniti na novim stranicama.

Sada je predlozak primjenjen u novom dokumentu.
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Ova stranica sadrzi jednaka podrucéja i sadrzaj kao i predlozak koji ste
kreirali.

Vazno: Ako premjestite pokazivaé miSa u neizmjenjivo podrucje
predloska kao Sto je podrucje logotipa ili navigacijskog gumba,
pokaziva¢ miSa cCe se izmjeniti kako bi vas upozorio da nemozete
pristupiti ovom podrucju.

3. Spremite vas§ dokument i ime datoteke
myTravelDetail mtnBike.html.



Uredivanje stranica baziranim na predloScima

Sada cete obnoviti myTravelDetail mtnBike.html dokument
azurirajuci izmjenjiva podrucja sa grafikama i tekstom koji se odnosi na
detalje o brdskom biciklizmu na Novom Zelandu.

1. U prozoru dokumenta kliknite Flash oznaku mjesta u titleCell
podrucju kako bi odabrali objekt koji zelite zamijeni.

2. U polju File property inspektora kliknite ikonu mape a zatim u
dijaloSkom okviru koji ¢e se pojaviti odaberite u Assets/swfs
text_mtnBike.swf.

3. U adCell podrucju kliknite Flash oznaku mjesta kako bi odabrali
objekt koji zelite zamijeniti.
4. U polju File property inspektora kliknite ikonu mape a zatim u

dijalo§kom okviru koji ¢e se pojaviti odaberite u Assets/swfs
bikeAd.swf.

5. Odaberite File > Open a zatim odaberite DW4_MtnBikeText.txt
kako bi otvorili dokument koji sadrzi tekst za ovo odrediste.

6. U DW4_MtnBikeText.txt kopirajte odlomak teksta ispod Cell 1 te u
myTravelDetail mtnBike dokumentu zamijenite aktualan tekst u
textCelll podrucju selektirajuci ga a zatim zalijepite kopirani tekst.

7. U DW4_MtnBikeText.txt kopirajte odlomak teksta ispod Cell 2 te u
myTravelDetail mtnBike dokumentu zamijenite aktualan tekst u
textCell2 podrucju, selektirajuéi ga a zatim zalijepite kopirani tekst.
Informacija o detaljima putovanja je obnovljena.

8. Zatvorite DW4_MtnBikeText.text.

9. U polje Title trake s alatima upiSite New Zealand biking.

10. Spremite vas dokument.
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Provjerite vas sajt

Prije nego postavite vaSe stranice na server uvijek trebate provjeriti vase
datoteke.Do sada ste naucili kako isprobati vaSe stranice
pregledavajudi ih u pretrazivacu a sada cete nauciti o ostalim alatima
Dreamweavera koji su korisni za kreiranje biljeski o datotekama i za
testiranje vasih stranica.

Prvo ¢ete nauciti kako dodati biljeSku u datoteku.
Kreiranje biljeSke (Design Note)

BiljeSke (Design Notes) su dobar nacdin za odrzavanje vaSeg sajta
umetanjem komentara u Site prozor vaSeg documenta. Koristite
biljeSke za izradu rasporeda rada, podsjetnika u datotekama ili za
komunikaciju sa suradnicima o dataljima datoteka ili sajta. Sada cete
kreirati Design Note za podsjetnik o napravljenim izmjenama na jednoj
stranici sajta.

1. U Dreamweaverovom prozoru Site (Site > Site Files), unutar Local
Folder izbornika odabrite DW4 Destinations.html.

2. U glavnom izborniku odaberite File > Design Notes.
Pojavit ¢e se dijaloski okvir Design Notes.

3. U Basic Info tabulatoru u Status pop-up izborniku odabrite Needs
Attention.

4. Kliknite ikonu kalendara kako bi dodali datum u polje Notes.

5. Kliknite u polje Notes i upisSite Need to create Devil’s Tower page te
dodajte linkove u dokumente.

6. Odaberite opciju Show When File Is Opened tako da se Design Note
automatski otvori kada se otvori i stranica.



7. Kliknite OK kako bi zatvorili dijaloski okvir.

Pojavit ¢e se ikona Design Note u stupcu Notes u izborniku Local
Folder.
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8. U prozoru Site odaberite DW4_Destinations.html i otvorite
datoteku.

Otvorit ¢e se dokument i njegov pridruzen Design Note pa lako
mozete vidjeti Sto je potrebno napraviti u ovoj datoteci.
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IzvjeStaji o sajtu

IzvjeStaje o sajtu mozete izradivati kako bi provjerili stanje HTML
datoteka i upravljali tijekom izrade.

Izradite izvjeStaj na nivou dokumenta, mape ili sajta. Sada cete izraditi
izvjeStaj kako bi vidjeli dali u vaSem sajtu imate bilo kakve dokumente
bez naslova.

1. Odaberite Site > Reports.
Pojavljuje se dijaloski okvir Reports.

2. U okviru za dijalog Reports u Report On pop-up izborniku odaberite
Entire Local Site a zatim u HTML Reports odaberite Untitled
Document.

3. Kliknite Run kako bi izradili izvjeStaj.

Pojavljuje se dijaloski okvir Results sa ispisom svih dokumenata bez
naslova stranice.

4. U listi File kliknite na datoteku kako bi je odabrali.

«Detailed Description» polje se azurira sa detaljnom informacijom o
upozorenju.

5. Kliknite Open File kako bi otvorili datoteku i potrebno ispravili.
Datoteka ¢e se otvoriti.

6. U polju Title trake s alatima upiSite Featured Destinations.
7. Pohranite i zatvorite datoteku kada zavrsSite.

8. Zatvorite dijaloski okvir Results.

Slijedeci koraci

Cestitamo, zavr§ili ste ucenje lekcija Dreamweaver priruénika. Sada
znate kako kreirati stranice, dodati sadrzaj i provjeriti vasSe stranice.
Ako zelite, mozete nastaviti kreiranje stranica i linkova za Compass
sajt. Vi sada znate kako izvesti sve potrebno kako bi dovrsili stranice (ili
mozete koristiti ve¢ dovrSene stranice kao referencu). Nakon §to ste
obnovili stranice pregledajte vase stranice kako bi isprobali rollover
efekte i linkove i bili sigurni da rade.

Ako zelite nauciti viSe o koriStenju Dreamweavera, pokuSajte sa
lekcijama Dreamweavera. U glavnom izborniku Dreamweavera
odaberite Help> Lessons a zatim odaberite jednu od lekcija.

Ako imate i Dreamweaver i Fireworks i Zelite nauciti kako raditi sa oba
alata istovremeno, pogledajte Dreamweaver i Fireworks priruc¢nik.

Ako ste zainteresirani za ucenje viSe o koriStenju HTML koda,
JavaScripta ili CSS-a provjerite Reference materijal koji dolazi u
sklopu Dreamweavera. Odaberite Windows > Reference.

Zahvala autoru ovog dijela. Posjetite web
stranice autora na http://prirucnik.cjb.net/



